Drupal core announcements: Issues adding new deprecations (for removal in Drupal 10) should be moved to 9.1.x

0 Flares Twitter 0 Facebook 0 Filament.io 0 Flares ×

Drupal 8 and higher provide a continuous upgrade path with a deprecation policy that requires old APIs to be marked deprecated and retained until the next major version. Drupal 8.8 was the final release to introduce new deprecations that will be removed in Drupal 9. This means that all new deprecations in 8.9 and higher will be retained in Drupal 9 and marked for removal in Drupal 10 instead.

For now, in order to continue work on issues that add new deprecations without causing disruption and noise for Drupal 9 readiness tools that detect deprecations, issues with new deprecations for Drupal 10 should be moved to the 9.1.x branch.

9.1.x is not yet open for development and so patches will not apply to it, but work can continue on these patches in the meanwhile by testing them against 9.0.x instead when the patch is uploaded:

The 'Test with' select field on Drupal.org issue file uploads

We may change our policy in the future and allow 10.0.x deprecations to be backported to 8.9.x and 9.0.x in certain cases (discussion in issue #3088246). Otherwise, 9.1.x will open for development in either March or April, depending on progress on Drupal 9 release blockers.