Blogs

Just another 陰陽 site

Security advisories: Drupal core – Less critical – Access bypass – SA-CORE-2020-006

|

Project: 
Date: 
2020-June-17
Vulnerability: 
Access bypass
CVE IDs: 
CVE-2020-13665
Description: 

JSON:API PATCH requests may bypass validation for certain fields.

By default, JSON:API works in a read-only mode which makes it impossible to exploit the vulnerability. Only sites that have the read_only set to FALSE under jsonapi.settings config are vulnerable.

Solution: 

Install the latest version:

Versions of Drupal 8 prior to 8.8.x are end-of-life and do not receive security coverage. Sites on 8.7.x or earlier should update to 8.8.8.

Reported By: 
Fixed By: 
,