The vulnerability is mitigated by the fact that Drupal core’s use of the Archive_Tar library is not vulnerable, as it does not permit symlinks.
Exploitation may be possible if contrib or custom code uses the library to extract tar archives (for example .tar, .tar.gz, .bz2, or .tlz) which come from a potentially untrusted source.
This advisory is not covered by Drupal Steward.
- If you are using Drupal 9.2, update to Drupal 9.2.2.
- If you are using Drupal 9.1, update to Drupal 9.1.11.
- If you are using Drupal 8.9, update to Drupal 8.9.17.
- If you are using Drupal 7, update to Drupal 7.82.
Versions of Drupal 8 prior to 8.9.x and versions of Drupal 9 prior to 9.1.x are end-of-life and do not receive security coverage.
- Drew Webber of the Drupal Security Team
Go to Source